Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 12-09-2010, 08:59 AM
Member
 
Join Date: Nov 2010
Posts: 215
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 1461
UNCjeepWK2 is on a distinguished road
Keyless go/lock issues...

Is anyone having some issues with the keyless lock button on the door handles as well as the car once in a while not recognizing the key to start for a time or two?

The keyless door-handle lock buttons work maybe 75% of the time... but I usually have to press it 2-3 times... sometimes more, for it to lock the car.

Also, the car recognizes the fob probably 90% of the time, but once in a while, especially after remote start, when I press the start button to actually drive, it says the key is not present (when of course it is). If it doesn't recognize it right away (which it usually does), it will after a few seconds...

Not a big deal... it's just sort of annoying when those things don't work properly... anyone else having these issues?
__________________

__________________
Reply With Quote
  #2  
Old 12-09-2010, 09:30 AM
Senior Member
 
Join Date: Sep 2010
Location: brOOklyn
Posts: 1,230
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 2580
JoeSchmoe007 has a reputation beyond reputeJoeSchmoe007 has a reputation beyond repute
Re: Keyless go/lock issues...

I did have door handle button not work several times, but much less than 25%, maybe 5-7%

I don't have another problem.
__________________

__________________
Reply With Quote
  #3  
Old 12-09-2010, 09:34 AM
Premium Member
My Jeep: 2011 3.6L WK2
 
Join Date: Sep 2010
Location: Indianapolis
Posts: 275
Thanks: 0
Thanked 7 Times in 4 Posts
Rep Power: 1590
IndyBob has a spectacular aura about
Re: Keyless go/lock issues...

So far mine has worked without problems. Both the button on the door and the key fob work fine for me.
__________________
Reply With Quote
  #4  
Old 12-09-2010, 11:26 AM
New Member
 
Join Date: Sep 2010
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
stides is on a distinguished road
Re: Keyless go/lock issues...

I'd replace the fob battery. I know it's new, but it could have been a bad one.

I think that's the first step in troubleshooting anyway.
__________________
Reply With Quote
  #5  
Old 12-09-2010, 12:06 PM
Technosavant's Avatar
Premium Member
My Jeep: 2011 3.6L WK2
 
Join Date: Jul 2010
Location: STL, MO area
Posts: 1,282
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 2713
Technosavant has a reputation beyond reputeTechnosavant has a reputation beyond reputeTechnosavant has a reputation beyond repute
Re: Keyless go/lock issues...

No problems here. The only thing I can say (beyond replacing the battery in the fob) is that when you push the lock button, do NOT put your hand around the handle. Push the button with your index finger like you're operating an elevator. If you put your hand around it the sensor will think you're trying to open the door and the doors won't lock.
__________________
Reply With Quote
  #6  
Old 12-11-2010, 09:11 AM
Premium Member
My Jeep: 2011 5.7L WK2
 
Join Date: Aug 2010
Location: NY/CT
Posts: 169
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1530
wk2overland is just really nice
Re: Keyless go/lock issues...

theres a TSB for remote proximity issues causing a no crank situation. should fix it.
had the same problem.

www.wk2jeeps.com/wk2_tsb.htm
__________________
2010 F150 Platinum Super Crew, Tuxedo Black on Brown.
My new lumbering giant. Makes the WK2 seem like a sports car.
Reply With Quote
  #7  
Old 12-12-2010, 09:40 PM
Premium Member
 
Join Date: Jul 2010
Location: Toronto, ON
Posts: 140
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1519
ostroveni is on a distinguished road
Re: Keyless go/lock issues...

Happened to me twice that I was not able to open the car with the remote. See the thread with my updates:
Any glitches after weeks of driving?

I have changed the battery and it did not happen again. For me, it always detects the key and I can open the door. I sometimes have problems locking the car. I push the button 2-3 times and it gets locked. It happened once that I got a message on EVIC that key is not recognized whn I pushed the start button.
__________________
Reply With Quote
  #8  
Old 12-29-2010, 04:47 PM
Member
My Jeep: 2011 3.6L WK2
 
Join Date: Nov 2010
Location: Wisconsin
Posts: 59
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1302
zer0kid is on a distinguished road
Re: Keyless go/lock issues...

Happened to my JGC purchased 11/24/10, Limited 3.6. About once a week my key wouldn't work; no buttons on the fob were recognized and using the physical key would unlock the door but not disable the alarm. From there, push button start wouldn't work as the key wasn't detected.

Occurrences became more frequently, to the point where three days went by that the fob didn't work. By this time I learned to carry both keys as the second one never failed.

It took several trips to the dealer to finally remedy. Testing under TSB 08-23-10a showed no faults so the PEM wasn't replaced. Programming a new 5-button fob didn't work (some functions and proximity unlock weren't working). Finally the Service dept contacted Chrysler with the issue and the response was to replace the PEM with no further reason given. After getting the module replaced I ultimately required a new fob as well to work properly. Interesting is that the PEM part number in the TSB has already been superseded by a new one.
__________________
Reply With Quote
  #9  
Old 12-30-2010, 03:52 PM
xj31's Avatar
Member
 
Join Date: Dec 2010
Posts: 112
Thanks: 0
Thanked 5 Times in 4 Posts
Rep Power: 1349
xj31 has a reputation beyond reputexj31 has a reputation beyond repute
Re: Keyless go/lock issues...

Looks like this might be a problem.I'm a tech at a dealer and I have seen this happen about 4-5 times already.All the cars are past the build date for the PEM flash/replacement.I have seen the evic say "Key Has Left Vehicle" when it didn't,"damaged key",yet it works in the ignition,RKE works and so does remote start.Passive entry won't work,starter button won't either.Pretty sure it's the PEM ,but I haven't done anything since I'm on vacation.If I find out anything,I'll let you know
__________________
Reply With Quote
  #10  
Old 12-30-2010, 08:54 PM
rdalcanto's Avatar
Member
 
Join Date: Sep 2010
Location: Salt Lake City
Posts: 622
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 1958
rdalcanto has a reputation beyond reputerdalcanto has a reputation beyond repute
Re: Keyless go/lock issues...

Does it make a difference if both keys are in the car at the same time?
__________________
2011 WK2
Overland 4x4 Hemi with Off-Road II
Mineral Gray, Saddle Interior
Tech Package, Rear DVD
Ordered September 18th, 2010
Delivered 1/14/11
Reply With Quote
  #11  
Old 12-30-2010, 11:03 PM
plynn7's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Nov 2010
Location: Delaware County,PA
Posts: 352
Thanks: 0
Thanked 5 Times in 5 Posts
Rep Power: 1784
plynn7 has a reputation beyond reputeplynn7 has a reputation beyond reputeplynn7 has a reputation beyond reputeplynn7 has a reputation beyond reputeplynn7 has a reputation beyond reputeplynn7 has a reputation beyond reputeplynn7 has a reputation beyond repute
Re: Keyless go/lock issues...

I am starting to have issues with mine as well. The other night I could not lock or unlock the door from the handle with the key fob in my pocket, but the key fob itself would work, so I left and came back three hours later and the handle now worked. Then tonight I could not get the remote start or the unlock/lock funtion to work from 30 feet away via the key fob, but when I approached and grabbed the handle the doors unlocked. Build date was 10/15
__________________
Reply With Quote
  #12  
Old 12-31-2010, 09:27 AM
xj31's Avatar
Member
 
Join Date: Dec 2010
Posts: 112
Thanks: 0
Thanked 5 Times in 4 Posts
Rep Power: 1349
xj31 has a reputation beyond reputexj31 has a reputation beyond repute
Re: Keyless go/lock issues...

I expect a fix will be made soon enough.The problem was supposed to be for vehicles built before 7-29-10 but I have seen it more often on later builds
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How To: Keyless Go LTrainGC Technical Tips/DIY/How-To 34 04-25-2011 09:14 PM
Keyless-Go Red G8R Troubleshooting/Problems 29 10-10-2010 09:03 PM
Keyless Go *If you don't want it* J13ntv Grand Cherokee - WK2 - 22 09-26-2010 02:34 AM
Keyless entry problems!! 99limited Audio, Video, Navigation & Electronic Modifications 12 06-28-2010 10:07 PM
Keyless entry JimCannici Grand Cherokee - WK 3 04-11-2010 12:15 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 03:16 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community